‘coreserver’ タグのついている投稿

WordPressをxreaからcoreserverへ移行

2010 年 6 月 14 日 月曜日

久しぶりの投稿だというのに,かなり重い内容となりそう・・・

こちらにも書い通り,Wordpressのバージョンが2.9にアップして以降,サーバ要件がMySQL4.1.2以上に。Xserverの方は,DBのバックアップでやや手こずったものの,まぁすんなりバージョンアップ出来た。

ところが,私が利用いているxreaのMySQLのバージョンは4.0.27。いろいろとややこしいことは判りませんが,MySQLのバージョンを4.1.2にアップするにはデータベース構造がくずずれる可能性があるとかで,同サーバのMySQLはこのまま。ということは,ここを使っている限り,Wordpressのバージョンも上げられないということ。

一方,corserverに移行すれば,MySQLは5.1.22。CORE-MINIなら利用料も+100円/年のみ。ということで,移行してみることにした。

ところが・・・まぁ,結構時間がかかってしまった。以下に顛末を。同様も失敗をされた方には参考になるかも・・・

  • CORE-MINIをお試しで利用開始
  • xrea側のWordpressでplugin類を停止
  • xrea側のphpMyAdminをUTF8に設定し,データベースをバックアップ
  • サーバー間コピーでドメイン用ディレクトリ以下をそっくりコピー
    (これはかなり便利・・・xreaにも同機能はあったのだが・・・機会が無かった)
  • DNSをCORE-MINI用に設定・・・しばらく待つ(15分も待てば十分?)
  • coreserver側のphpMyAdminにバックアップファイルをインポート

さぁ,しばらくすればcoreserver側への移行が完了しているはず。

結果は悲惨。???だらけで,ログイン使用としても拒否されて入れない。

それからというもの,DNSをxreaに向けては,バックアップのやり直し,文字コードを替えてみてcoreserever側で確認・・・ダメ・・・というのが続いて,仕方なく

  • WordPress側のエクスポート機能を利用してバックアップ
  • coreserever側に最新バージョンのWordpressをインストール
  • xrea側の設定に合わせてwp-config.php等を更新

当然なのか,一応coreserver側でも正常にWordpressを見ることが出来るように。

しかし,バックアップできていないデータもかなりあるようで,plugin,images,thema等は一からインストール,設定が必要。これは大変。

そこで,この記事が役に立った。旧バージョンのWordpressでは文字コードの設定方法が違った様だ。

define(‘DB_CHARSET’, ‘utf8’);

を追加するだけで,普通にWordpressが読めるようになった。おそらく,バージョンアップの際に,最新のwp-config.phpをベースに旧wp-donfig.php情報で更新するという手順を踏めば問題なかっただけのよう。勉強になった。

しかし結局,coreserverへの移行は一旦諦めることに・・・・それは次回に